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Przygotowanie do pracy w programie Quartus
1. Utworzy¢ na dysku komputera (w katalogu Moje_dokumenty) folder dla klasy np.: 3D

2. W folderze klasy zaktadamy foldery dla poszczegdlnych grup laboratoryjnych, np.: 1 2 D

v = 13D

nr w dzienniku ucznia

3. W folderze grupy beda zaktadane katalogi realizowanych projektéw implementowanych w uktadach

programowalnych FPGA np.:1_2 D_BRAMKI

Moje dokumenty folder klasy
\ J
(" ¢ N\

3D folder grupy
\ J
( ¢ N .
120D folder projektu

- - J
( ¢ N

1_2_D_BRAMKI
~ J

4. Nalezy pamietac o tym, aby powstajgce kolejne pliki w programie Quartus Il graficzne badz symulacyjne
byty zapisywane zawsze w katalogu projektu (1_2 D BRAMKI) pod takg sama nazwa:
. 1 2 D BRAMKLbdf
- 1 2 D BRAMKILvwf

Tworzenie nowego projektu
1. Uruchomi¢ kreator New Project Wizard (File > New Project Wizard)

Fle Edt View Project Assignmerts Processng Toos Window Hep

[ pow. vt | ] Hixzsees o> 2ok e |ue]
& Cpen, [ere I S—
Cjose. CirieFa

& Open Project.., Cirl+a
Cornvert MAX+PLUS 1T Project...
Saye Project

Close Project

bl 500 Ciilts
Savehs,
Save ClrrertReport Section As.,

ElePropertics..,

_— A D A
Create {Update » L= .
EXport.,
T QUARTUS II
R PageSetip, .
B Print Preview Version 8.1
& prirte. chlsp
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New Project Wizard: Directory, Name, Top-Level Entity [page 1 of 5]

‘What is the working directory for this project?

[C\Documents and Befings wuser\aje dokumentyy 3DV 2 D1_2_D_BRAMKI J

Whatis the name of this project?

|1 _2_D_BRAMK

“hat is the name of the top-level design entityfor this project? This name i\ \ase sensitive and must exal
match the entity name in the design file

1_2_D_BRAMEKI

Use Existing Project Seflings

2. Wprowadzenie katalogu i nazwy projektu

Po wybraniu opcji Next uzyskamy okno umozliwiajace
definiowanie katalogu inazwy dla nowego
projektu

Nazwa katalogu na dysku

twardym, gdzie s

przechowywane pliki projektu

Nazwa projektu

Nazwa bloku opisujacego
porty

<Back

MNext >

Finish ‘ Anuluj ‘

New Project Wizard: Add Files [page 2 of 5] gl

Select the design filss youwantta include inthe projsct, Click Add Allo add all design files in the project
directory to the project. Note: you can always sdd design files (o the project later.

File name: | J
Fils nama [Tvpe [Libr__[Design entry._[HDL version Add Al

L

Specity the path names of any non-default libraries.

User Libraries...

MNext >

< Back Finish

Anuluj |

New Project Wizard: Family & Device Settings [page 3 of 5] @

Selectthe family and devics you want to target for compilation

Device family Show in ‘Available device' list

Family: Package Aty =
Fin count: Aty a
Speed grade; Ay =

Target device
" Auto device selectad by the Fitter v Showadvanced devices

@ Specific devics salected in ‘Available devices' list =

Available devices:

Narme [cCos. [LEs  [User. [Mem. [Emb. [FLL  [Glob. | -

EPZC20AFZEBAT 12y 18752 152 239616 52 4 16

EP2C20AF25615 12 18752 152 239616 52 4 16

EP2C20AF484A7 12Y 18752 315 239616 52 4 18

EP2C20AF43418 12% 18752 315 239616 52 4 16

EP?C20F256CE 12y 18752 152 239616 52 4 16 E

EP?C20F256CT7 12Y 18752 152 239616 52 4 16

EP2C20F256CE 12Y 18752 152 239616 52 4 16

EP2C20F256I8 12¥ 18752 152 239616 52 4 18

EP2C20F484CE 12v 18752 315 239616 52 4 16

EPZC20F484CT 12 18752 315 239616 52 4 16 %
2

-

< Back Next> Finish I Anuluj I
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3. Dodanie do projektu istniejgcych plikow

Kolejne okno dialogowe umozliwia dodanie do tworzonego
projektu istniejgcych plikow. W naszym przypadku nie
7zrédtowego -

mamy do dyspozycji gotowego pliku

wybieramy Next

4. Wybdr uktadu programowalnego

To okno dialogowe umozliwia wybdr rodziny uktadéw
uktadu,
na ktérym dokonana bedzie implementacja. W naszym

programowalnych, a nastepnie konkretnego

uktadéw
i uktad

rownowazna jest
w sktad

wybraé rodzine

programowalnych  FPGA Cyclone I
EP2C20F484C7. Konfiguracja ta
z wybraniem struktury FPGA, ktdéra
zestawu edukacyjnego Altera_DE_ 1

przypadku nalezy

wchodzi



= O Specyfikacja narzedzi firm innych niz Altera

New Project Wizard: EDA Tool Settings [page 4 of 5]

e Chcac wytacznie korzystac z narzedzi oferowanych w ramach $rodowiska
————— Quartus_ll, nie zaznaczajac zadnego pola wybieramy Next
\ B . . .
r 6. Podsumowanie ustawien tworzonego projektu
Toanane: [ = W ostatnim oknie dialogowym kreatora, w ktdrym przedstawiono
[ I L.
r wybrane ustawienia projektu nalezy wybrac opcje Finish
Toeteme }(ND"E) j New Project Wizard: Summary [page 5 of 5] B‘
e \When you click Finish, the project will be created with the following settings:
Project directory;
C./Documents and Settings /user/Moje dokumenty/30/1_2_D/1_2_D_BRAMEKI/
Project name: 1_2_0_BRAMKI
O ’—|NE>“> =i ol Top-level design entity: 1_2_D_BRAMKI
Nu;r]nbevufmesgadded 0
Nurnber of user libraries added 0

Device assignments

Farmily name Cyclone I

Device: EP2C20F484C?
EDA tools

Design entry/synihesis: <None>

Simulation <None>

Timing analysis <None>

Operating conditions
Core valtage 12V

Junction temperature range:  0-85 °C

<Back Finish Anuluj

Specyfikacja projektu w edytorze graficznym
1. W celu uruchomienia edytora graficznego wybieramy: File > New W oknie dialogowym nalezy
wybraé Block Diagram/Schematic Fil&chemat zapisujemy komenda File > Save Aspod nazwa
np. 1 2 D _BRAMHK.bdf w katalogu 1_2_D_BRAMKI
m 2. Przed zapisaniem pliku nalezy wybra¢ opcje
Add file to current Project

Mew Quartus || Project

SOPC Builder System Save As X
-I- Design Files Zapiszw |2 1_2_D_BRAMKI | il
HDL F|E! \_;\j =
EDIF File L
State Machine File E(}
Systernverilog HOL File Pulgit
Tel Script File
Yerilog HOL File 574
VHDL Fila Moje clakumenty
- Memoary Files ﬁ!
Hexadecimal (Intel-Format) File M katnputar
Mermaory Initialization File
- Yerification/Debugging Files ‘:gl
In-System Sources and Probes File G e
Logic Analyzer Interface File S = e I
SigneTag  Logic Al il e

Cither Files [¥ Addfile to current project
AHDL Include File
Block Symbal File
Chain Description File
Synopsys Design Constraints File
TextFile

oK | Cancel
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3. Edytowanie schematu
« W celu wprowadzenia symboli elementéw tworzonego schematu klikamy dwukrotnie lewym
przyciskiem myszy na pole edytora i wybieramy

& Cyclone Il EP2C20F484,
* 12 DBRA. &

Q BRAMKI/ D_BRAMKI D_BRAMKI - [1_ D df*] 7 . . . . . . .
o ; z wiasciwej biblioteki kolejno zgdany blok
Dedd & B 1_2_D_BRAMKI Y| @LG T rWr vH k&0 Qe . . .
“x 5120 oA v I (element) funkcjonalny. Nastepnie nalezy
Entity [Logic Cells [Dedic
& Cyclone I: EP2C20F484C7 =] , . . .
AR I m——c wykonaé potaczenia pomiedzy wprowadzonymi
A Libraries:
o B & c/altera/91sp2/quartus/librar.. A
=] funct — H H H H
glf| G s elementami (np. miedzy pinami a badang
B B primitves
- gg ‘buﬁev
K 9% bramka).
F 4 and3
= & andq
7 L3
a o ande
A band12
. | 2 5 b .
= s 2 ¢, Quartus Il - C:/Documents and Settings/useriMoje dokumenty/3D/1_2_D/1_2_D_BRAMKI/1_2_D_BRAMKI - 1_2_D_BRAMKI -
Flow: [Compilation =] = | frez J ﬁ Fle Edit ¥iew Project Assignments Processing Tools Window Help
i =l e DSEE & @B o 1_2_D_BRAMKI e gl k@8R e
‘ompile Design (=]
G Analysis & Synthesis oll = Projsct Navigatar - * ) 1_2_D_BRAMKLbdf |
E-»Fiter (Place & Route) Ny Enity [ Logic Cells [Dedic
B--P Assembler (Generate programming file B
G- b EDA Netlist Writer B - H BRI pin_hame? -
Eng
¥, Quartus Il - C:/Documents and Settings/user/Moje dokumenty/3D/1_2_D/1_2_D_BRAMKI/1_2_D_BRAMKI - 1_2_D_BRAMKI - [1_2_D_BRAMKI.bdf*] O
o Fle Edt View Project Assignments Processng Tools Window Hep -
DeEd & B 1_2_D_BRAMKI T HsBRE P D k8 A e -1
Project Navigator ~X 9 1_2_D_BRAMKLbdf* | =
Entity 3
S
=

iz

] i

st

SO0 >~ d

. Pinom wejsciowym i wyjsciowym nadajemy odpowiednie nazwy klikajagc na nie lewym przyciskiem
myszy: np. wejsciom — nazwy SW[0] i SW[1], a wyjsciu LEDR[0]. Nazwy te muszg by¢ zgodne z nazwami
stosowanymi w zestawie DE_1.

Pin Properties | Pin Properties
General Imeaﬂ General IFormat}
To create multiple pins, enter a name in AHDL bus notation (for example, "name[3..0]", To create multiple pins, enter a name in AHDL bus notation (for exarple, "name[3..0]").
arenter a comma-separated list of names or enter a cornrma-separated list of names
Pin name(s): pin_narme Fin narmeis) |LEDR[U]|

4. Kompilacja projektu

Kompilujemy stworzony projekt wybierajac ikone P . Po kompilacji wyéwietla sie nam okno dialogowe
z podsumowaniem. Kompilacja moze by¢ udana lub nie, tak jak to przedstawiajg okna dialogowe przedstawione
ponizej.

port - Flow Summary]

9 Fle Edt vew Project Assgrments Frocessng Took Widow Hep
DSUE@ & & [1_2_D_BRAMKI T He@we | D> 2|88 ke

12,0 BRAMKbS

—i=% | & Compilation Report - Flow Summary
[Eny TCogic o [
& Cydons I EP2GAF 7T

2 1.2.D_BRAMK &g 1 0(0)

&n

.
S 1) Ful Compilation was successfil (4 warnings)

a=
Sl b T
Sccashi-Tue 9152535 2o
16280 VLA SP 251V Edton
2.0 crw Ok
oo

SE=Fow 05 Summary.
clona

&8 FowLog
G Aralyss 8 Synthesis
- G Fite

G Assembler

# G Timing tnsyzer

EP2CanFBICT
Final

Yes

1718752 (<1%)
1418752 (<1%)
0/18752(0%)

& >

0
37305 (<1%)
0

ol i
Total memorybis 0230516 (0%)
Enosaded Mulipier it dlements  0/52(0%)
ToelPLL 0/4(0%)
< 3 |5 .
v
=4
12D BRAMKE -¢ 12 D BRAMKE —-timing_anslysis_only
®
Tnt 1T Pull compile
<
4 Symem @ |Processing (51) f Exaits |, ko (@) J, Wamna() G na )} Evor ) Suppressed () Fioa [
& Meseoge vorio [
| EnEy 7=
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Il - C:/Documents and Settings/user/Moje dokumenty/3D/1_2_D/1_2_D_BRAMKI/1_2_D_BRAMKI - 1_2_D_BRAMKI - [Compilation Report - Flow Summary]

View Projct Assgments Frocessng Tools Widow Hep

1_2_D_BRAMKI |G e PR BD @Y ae

| & Compilation Report - Flow Summery.

\ij) Full Compilation was MOT successful (4 errors)

T2 lol's
1o

Oyelore |
EP2CR0F484CT

o @2 Analysis & Syrtess

nnnnnn

W przypadku nieudanej kompilacji w raporcie
zostaja wyszczegdlnione zaistniate btedy

Multplier Sbitelements.

w projekcie.

5. Przyporzagdkowanie pinéw

. Korzystajac z informacji zawartych w dokumentacji zestawu DE_1 [1] nalezy przyporzadkowaé wejsciom
SW[0], SW[1] oraz wyjsciu LEDR][O fizyczne piny uktadu EP2C20F484C7.

UWAGA! Nieodpowiednie przyporz adkowanie pindw uktadu scalonego mo ze spowodowa €
po uruchomieniu programu uszkodzenie zestawu labora toryjnego DE1. Kompilator nie zgtosi
zadnego ostrze zenie w tym przypadku. Szczegoélnie niebezpieczne jes t zdefiniowanie pinu

bedacego wej sciem uktadu scalonego jako pinu wyj  s$ciowego.

- Aby unikngé pomytek nalezy zaimportowaé gotowy plik DE1_pin_assignments.cSw pliku tym
zdefiniowano wszystkie piny uktadu EP2C20F484C7, przy czym nadano im nazwy zgodne z nazwami
pindw zawartymi w [1 Z menu Assignments > Import Assignments

Import Assignments

Specify the source and categories of assignments to import

File name |C:fAItera DE1 LG (D)#DEW_tutDria\s/design_f\lestE1_pin_asswgnmems.:sviJ

[v' Copy existing assignments into 1_2_D_BRAMKLgsf b efare importing Achvanced
0K | Cancel

Adres na komputerze w pracowni !!!

<méj_komputer/dokumenty_udostepniane/AItera DE1 v0.6(D)/DE1_tutorials/design_ﬂles/DE1_pin_assignments.csv>

«  Po przyporzadkowaniu pindw ponownie kompilujemy stworzony projekt wybierajgc ikone: ' » . Schemat

projektu przedstawiono ponize;.

¥, Quartus Il - C:/Documents and Settings/user/Moje dokumenty/3D/1_2_D/1_2_D_BRAMKI/1_2_D_BRAMKI - 1_2_D_BRAMKI - [1_2_D_BRAMKI. bdf] g
e Fle Edt View Project Assignments Processng Tools Window Help &l x
DL & el 1_2_D_BRAMKI ~l¥rewe LA Rk AN ECRR R

EEE S =L 1_2_D_BRAMKLbdf |

Entity | Logic Cells [ Dedic v

4y Cyclone |l: EP2C20F484C7

L% 1.2.D_BRAMK dg 1M () 3 iipE

Lo e i Rl
PIN_L21 i inst s [PIN_R20 |

J0o > |6
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Symulacja realizowanego projektu

Symulacja projektowanego uktadu ma na celu potwierdzenie, ze ukfad zostat zbudowany prawidtowo.
Wykonuje sie jg przed zaimplementowaniem projektu w uktadzie programowalnym. Proces weryfikacji projektu
nalezy rozpoczg¢ od utworzenia pliku zawierajgcego testowe przebiegi czasowe wszystkich wejs¢ oraz
odpowiadajgce im przebiegi czasowe wszystkich (lub wybranych do analizy) wyjs¢ projektowanego ukfadu,
ktorym nalezy nada¢ warto$¢ nieokreslong. Wartosci wyjs¢ zostang okresSlone w trakcie symulacji.
Aby utworzy¢ nowy plik zawierajgcy przebiegi czasowe:

1.

) C'¢'osovm Vector Waveform File

¥ Quartus |l - C:/Documents and Settings/user/Moje dokumenty/3D/1_2_D/1_2_D_BRAMKI/1_2_D_BRAMKI - 1_2_D_BRAMKI - [Waveform1.vwf]

Otwieramy okno edytora symulacji Waveform Editoiybierajgc z menu File > New a nastepnie w oknie

MNesw Quartus || Project

SOPCBuilder System

BFl\e Edit View Project Assignments Processing Tools Window Help

= Design Files DEEa@ & 1_2_D_BRAMKI || K@ e Tl E 8% Ae
AHDL File Froject Navigator “x  n Waveforml vwi I
Block Diagram/ Schematic File Entity [Logic Celis [Dedic
EDIF File &y Cyclone I EP2C20F48407 B Master Time Bar. 2326ns 1| +| Pointer 1485 ns Interval

State Machine File & 1.2.0 BRAMK fg 1
Systemyerilog HDL File
Tcl Script File
Werilog HOL File
WHDL File

=-Memaory Files
Hexadecimal {Intel-Format) File
Memary Initialization File

=-Verification/Debugging Files

0

0ps 10.0ns
value st |F-P ;

200ns

Neme | 2325 ns

G 2E»

2326 ns

In-System Sources and Probes File
Logic Analyzer Interface File
SignalTap Il Logic Analyzer File

i i File

2.

e
= Other Files
AHDL Include File
Block Symbal File
Chain Description File
Synopsys Design Constraints File

Text File
Zapiszw, |22 1_2_D_BRAMKI ~| ememEr
e IDincremental_db
dnkinemy
3. Ustawienie czasu symulacji i rozdzielczosci czasowej
Przed przystgpieniem do nadawania wartosci sygnatom | wascres
wejéciowym nalezy ustali¢ czas trwania symulacji oraz | 2%
rozdzielczos¢ czasowa, czyli najkrétszy czas trwania zadanego <)

stanu logicznego. Nalezy przy tym uwzgledni¢ fakt, ze czas
catej symulacji od
w projektowanym uktadzie (np. tak aby sprawdzi¢ dziatanie

mozna  uzaleznic¢ ilosci  wejs¢

Zapisywanie pliku Vector Waveform File

Moje migjsca.
sieciowe

Wybieramy z menu File > Save A$zapisujemy tworzone wektory
testowe (test vectorspod nazwg 1_2 D BRAMKIL.vwf w katalogu
projektu 1_2_D_BRAMKI !11!

Nazwa pliku [1_2_0_srama

il

Zapisz jakotyp. [Vector wavetarm File (it

[V Add fileto current project

Zapis?
Anuluj

wszystkich kombinacji wejs¢) lub od czasu potrzebnego do zamkniecia cyklu pracy uktadu (np. petnego cyklu

pracy licznika). Przy ustawianiu rozdzielczosci czasowej nalezy pamietac, ze czas propagacji sygnatdw moze

wynosi¢ nawet 30 ns, czyli krétszy sygnat moze nie zosta¢ poprawnie zinterpretowany lub skutek jego zmiany

moze sie przesungc¢ poza nastepng zmiane stanu.

Ustawienie rozdzielczosci czasowej nastepuje po wybraniu polecenia Edit — Grid Size.,

natomiast czas catej symulacji ustawia sie poleceniem Edit — End Time.

W podanym przyktadzie sg dwa sygnaty wejsciowe, zatem rozdzielczo$é¢ Grid Sizezostata ustawiona na 50 ns,

a czas catej symulacji End Timena 200 ns.

End Time X
m e -]
Defout extnsion optons:
Base grid on Extansionvalue: |Last clock patiern =
Enctime extonsion pr signa:
-~
SgnaiNeme [t | e | Eemsionvalue
= sw ot B Getout extonsion
= 1eoR Ouput Binery Defeut extension
@ Time period:
Feriod |ED |ns -
ok | camce | o
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4. Chcac obserwowac przebieg symulacji dla ustawionego okresu symulacji wybieramy z menu
View > Fit In Window
5.  Wprowadzanie portéow we/wy

Klikamy dwukrotnie w kolumne Name(lewa strona edytora) otwierajgc okno Insert Node or Bsl

Insert Node or Bus §| fiode finder X
— ] Fiter:[Pins: an ~] Custormize & l:'
MName: | Ok 2 D_BRA =] | ¥ nclude subeniiies i | 2 Cancel
Nodes Found Selected Nodes:
Type |INPUT Cancel Narme Assignm... | Type Creatol Naime [Assignm.. [ Type [ cCreatar

Yalue type |9'LBVB|

- LEDR(0] FINR20  Quipwt  Userer
MNade Finder... W Unassig.. InputGro.. Userer

=]

SLEDR Unassig. OuputG.. Userel
=]
id

B SW[0] PIN_L22  Input Userer
Fiadix |Binary = 5W(1] PIN_L2T  Input Userel
Bus width: |1
Startincex: |U

[ Display gray code count as binary count

3 A

Nastepnie wybieramy Node Findei w zaktadce Filter wybieramy Pins: all. Klikamy na przycisk List i wybieramy
z listy porty wejsciowe SW[0] i SW[1] oraz port wyjsciowy LEDR[O] klikajgc w przycisk > . Magistrale LEDR i SW

mozemy réwniez przenie$¢ na prawg strone. Wowczas obserwowane sygnaty beds jednoczesnie opisane
w wybranym kodzie.

Insert Node or Bus

!

Narmed [* ~| Fitter:[Pins: all v Custamize List Q oK
. > D_BRA - ¥ Include subeniities ancel
MName: Ok 2 v Cancel
Nodes Found Selected Nodes
Type: |"‘“Mult|p\e ltems* - Cancel Name Assignm... | Type Creatal Name [Assignm... [ Type [ Crestor
D LEDR Unassig.. OuiputG.. Userer @[1_2_D_BRAMKISW Unassig.. InpwtGra.. Userer
0 PIN_R20  Ouiput___ Userel -1 _2_D_BRAMKISW[I] PIN_L22  Input Userel
Walue type |9'L9VE| hd MNade Findar. S Unassig.. InputGro.. Usere -1 _2_D_BRAMKISW[T] PIN_L21  Input Userel
S0 PIN_L22  Input Userer {1 _2_D_BRAMKILEDR. Unassig.. OuputG.. Userer
Fiadi |Einary - 5[] PIN_LZT  Input Useren 2|1 2_D_BRAMKILEDR[]  PIN_R20  Oupwt  Userer
adix
Bus width | tultiple ltems R
Start index: |"’"Mu\tip|e terns™ >
|
[ Display gray code count as binary count «

6. Ustawianie stanéw portéw wejsciowych

Stany portéw wejsciowych edytujemy zaznaczajagc myszkg wymagany przedziat czasu, a nastepnie klikamy
prawym przyciskiem myszy i z menu Value wybieramy zadany stan / typ sygnatu. Chcac np. ustawi¢ wartoscé

1

jedynki logicznej nalezy wybra¢ Value >Forcing High (1Jub wybraé ikone It na pasku narzedziowym edytora
przebiegéw czasowych. Nalezy np. ustawi¢ wartos¢ logiczng ,1” dla przedziatu czasu od 100 nsdo 200 ns
dla portu SWI1] oraz dla przedziatéw od 50 nsdo 100 nsi od 150 nsdo 200 nsdla portu SWJO0].

¥ Quartus Il - C:/Documents and Settings/user/Moje dokumenty/3D/1_2_D/1_2_D_BRAMKI/1_2_D_BRAMKI - 1_2_D_BRAMKI - [1_2_D_BRAMKI.vwf*] [ W
4 Fle Edit View Project Assignments Processng Tools Window Hep BE
DSH@ & o 1_2_D_BRAMKI @ o r ooy & B 4e
FrOBIHRLor £ 5 1_2_D_BRAMKIAF | & Compilation Report - Flow Summary | 3 1.2 D_BRAMKILvwf* |
Eniity. [ Logic Cells [Dedic
&) Cydons I EP2C2OFA8ACT B3 Master Time Bar 2335 ns || Pointer 512808 Interval 27.94ns Start End
L2 1_2_D_BRAMK &g 1M 0w
3 et PP 50.0ns 100005 1500 ns ZUUUn%
A Neme | 555 23%ne
%
EIEED E 00 ] 10 i
o1 m| s T
a2 8 - \
# 23| =3 LEDR B 4
ar @4 L.m B

7. Symulacja
Aby wykonac¢ symulacje trzeba:

* wygenerowa¢ Functional Simulation Netlistvybierajgc z menu Processing >Generate Functional
Simulation Netlist

H

* nastepnie wybiera¢ z menu Processing >Start Simulatidab klikngé na ikone
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W srodowisku Quartus mozemy wykonaé¢ dwa typy symulacji:

symulacji  ustawiamy

przypadku ustawiamy Timing.
symulacji mozemy
propagacyjne, ktdre wystepuje
uktadzie. Zmiana

stanu na

nastepuje

4 ”
z,0” na,l”.

ocuments and Se

zauwazyc

wyjsciu
po ok. 5,5 ns w stosunku
w ktérej wejscie SW[0] zmienia po raz drugi stan

Z menu

Po zrealizowaniu
opdzinienie
W rzeczywistym

LEDRI[O]
do chwili,
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Simulator Setings
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Simulation Output Files
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55N Analyzer

General

Select simulation options
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Assignments > Settings nastepnie dla Simulator
Setingsw polu Simulation modew omawianym

X
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= |
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Konfiguracja ukladu FPGA
Aby umozliwi¢ konfiguracje uktadu FPGA znajdujgcego sie na ptycie DE_1 nalezy:
e zestaw DE_1 podtaczy¢ do komputera poprzez ztgcze USB,
» zainstalowac sterownik USB-BlasterPodczas pierwszego podtaczenia zasilanego zestawu do komputera
system Windows zapyta o lokalizacje sterownika, nalezy wowczas wybra¢ katalog Quartus/ drivers/
usb_blasterPo zainstalowaniu sterownika mozna przystgpi¢ do programowania uktadu FPGA.
Konfiguracja uktadu FPGA znajdujgcego sie na ptycie DE_1 moze by¢ realizowana w dwu trybach:

e JTAG (Joint Test Action Group) — w tym przypadku kod wynikowy kompilacji przesytany jest
bezposrednio do uktadu FPGA — Cyclone Il _ EP2C20F484C7. Uktad FPGA zaprogramowany w tym trybie
pamieta dane konfiguracyjne tak dtugo, jak dtugo witgczone jest zasilanie. Zaletg tego rozwigzania jest
mozliwos$¢ przeprowadzenia nieskonczonej liczby poprawnych przeprogramowan pamieci SRAM,
natomiast wadg utrata programu po wytgczeniu zasilania.

e AS (Active Serial) — w tym przypadku uktad FPGA wykorzystuje pamieé typu FLASH, do ktdrej wpisywane
sg informacje o konfiguracji. Dane te sg pamietane réwniez po wyfaczeniu zasilania. Nie ma potrzeby
ponownego konfigurowania uktadu.

1. Programowanie w trybie JTAG

W celu zaprogramowania uktadu w trybie JTAG nalezy ustawi¢ przetacznik RUN/PROG
znajdujacy sie na ptycie Altera DE_1 w pozycje RUN. Modut umozliwiajgcy konfiguracje
wywotujemy wybierajac z menu Tools > Programmelub klikajac ikong . 3 [@

W module tym wybieramy tryb programowania JTAG oraz sprzet docelowy USB-Blaster
(za pomocg polecenia Hardware Setup

HO_uarlus Il - C:/Documents and Settings/user/Moje dokumenty/3D/1_2_D/1_2_D_BRAMKI/1_2_D_BRAMKI - 1_2_D_BRAMKI - [1_2_D_BRAMKI. cdf] E@@

File Edit Processing Tools \Window

& Hardware Setup.. No Hardware hade: {JTAG *| Progress 0%

| Enable reaktime ISP to allow background programming (for MAX Il devices)

Secur ISP
Bit CLAMP
[m] [m] ]

Pragra. Blank-
Canfigu YTy | Check

12 D _BRAMKIsol EP?CZOF484 O01B04DB  FRFFFFFT m]
@ Add File..

8 Add Device. ‘

Erase

‘ File Device IChecksum ‘Usercude Exam\..|
—

W polu File mozemy zauwazy¢ plik o nazwie ,1 2 D BRAMKI.sdf a w polu Deviceznajdujacy sie
na ptycie DE_1 uktad FPGA — EP2C20F484C7. W przypadku braku na liscie wymienionego pliku nalezy go dodac
wybierajgc Add File W oknie dialogowym modutu Programmer nalezy zaznaczy¢ opcje w polu
Program/Configure

Konfiguracje uktadu EP2C20F484C7 rozpoczynamy klikajac na Start.

Po przeprowadzeniu konfiguracji mozemy przystgpi¢ do fizycznego testowania przygotowanego
projektu ,1_2_D_BRAMKI".
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Materialy zrodiowe

[1] DE1 Development and Education Board User Manual (DE1_UserManual_v1018.pdf)
[2] Artur Cichowski, Wojciech Sleszyriski: Wprowadzenie do systemu projektowego Quartus |I
PG WEIA 2007 (cwiczenie_1_2_QUATRUS_II.pdf)
[3] Quartus Il Introduction Using Schematic Design (tut_quartus_intro_schem.pdf)
[4] Krystyna M. Noga, Marcin Radwanski: Projektowanie  uktadéw programowalnych  w $rodowisku
Quartus Il z wykorzystaniem edytora tekstowego, AM Gdynia 2008
[5] http://www.altera.com
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